2014 Focus SE wont start HELP!!!

Mikhail

New Member
Messages
2
Reactions
0
#1
What happened; Going down the highway with cruise control set on 58mph. I glanced at speedometer and saw I was only going about 50 so I hit the gas but it just didnt do nothing. I pulled over and the car completely shut off. After that it refused to crank and when attempting to start I hear it but it sounds all most like theres no resistance to the starter turning over.
I was considering a broken timing belt until Gates (the belt company) replied to my email letting me know my 2.0 GDI Duratech motor had a timing chain. Now I was thinking if my timing chain had broken at 50+mph I would have heard some kind of noise and when it lost power there were no noises of any kind except the normal ones.
I can hear the fuel pump in the tank but I know nothing about the high pressure pump ran by the cam shaft. Theres no bad fuses. I switched relays around to make sure they were all ok.
Recent history; Its had a slow coolant leak (radiator) I have had no luck finding and have been thinking it may be the water pump going out. Haven't rented a pressure tester to really check the system yet.

Any Ideas please throw them my way and they will be very much appreciated. Thanks for your time!

P.S. It has 95k miles
 
Messages
2
Reactions
0
#2
Well, I came across your post and likely way too late but it was while searching for help on my Focus. Seems to be very little help here on DIY repair but I might throw in that I would look at electrical causes for this sudden shutdown. Things like a bad ignition switch and as a second thought, it might pay to look at how much weight is on the keychain as it can lead to early death of the contacts on the switch.
 

Similar threads



Top