• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Ford Focus Forum and Ford Focus community dedicated to Ford Focus owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Ford Focus Forum today!

Battery/starter issue?

damianbe

New Member
Messages
2
Likes
0
#1
Alright so I have a 2010 ford focus s. Started having this problem maybe a month or two ago.

Sometimes my ride starts up like normal and somedays I'll have to put the key in ignition and turn it till all my lights on my dash turns on and nothing. I'll take the key out and wait about 5 to 10 seconds before I try again and it starts like nothing.

I tried taking off the battery cables and cleaned the battery posts side they were kinda corroded. After doing that and connecting the battery again, still does it sometimes.

As of now it's still doing it, but the car starts eventually.

So I suppose my question is is it the starter or battery? Not sure where my starter is located but maybe it's that? My battery is about a year and a half old, so I don't think it's that.
 
OP
D

damianbe

New Member
Messages
2
Likes
0
Thread Starter #3
Okay, I did that and the battery is good. Read 12 or so when engine was off and 13 when the engine on.

I'm kinda thinking now it's the starter or maybe a new key? The cables running from the battery look good.

I did have my brother help me hit the starter with a hammer while I try to start but no luck.
 


Top